Bienvenue sur la page communauté Sooth ERP, où vous pouvez poser vos questions. Inscrivez-vous (via le login de Mantis)

soothERP : est-ce que l'aventure se poursuit?

0 votes
Bonjour,

je suis utilisateur de LMB depuis plus de 5 ans, mais ça fait bien 3 ans que je n'avais pas pris le temps de mettre à jour mon produit  : XAMP lite 1.7.1 + LMB 2.046.0

or je m'en sert en production pour ma petite TPE.

j'ai alors voulu faire évoluer tout ça et c'est là que je me suis apperçu que j'avais loupé le train : arrêt de community par LMB et disparition des sources et surtout du forum qui était très riche d'info et d'astuce. Torcos aurait fait une copie du forum avant sa fermeture, d'après l'un de ses post sur la toile. aurriez-vous l'url pour que je trouve mon bonheur.

ensuite lorsque j'aurais réussi à monter une base Xamp plus résente, réimporté ma base Mysql, réussi à upgrader le produit jusqu'à la version 2.071.0, alors seulement je pourrais espérer pourvoir vous rejoindre en migrant ma base vers SoothERP.

mais je me pose egalement la question de savoir si la communauté SoothERP est active et si les dev et correctifs se poursuivent. je pourrais être un bon contributeur de remonté de bug ou d'idées de fonctionnalités, mais pas une aide au  dev :-( je n'ai pas les compétences :-(

Merci par avance si vous avez le temps de me faire une petite réponse.

Bon dimanche à tous

Frederic
posté Fev 8, 2014 dans la catégorie Divers par fpacaud69 (170 points)

1 Réponse

0 votes
Bonsoir et bienvenue, pour ce qui est des sources LMB, elles sont encore en ligne à ce jour (seul le lien à disparu de leur site): ftp://ftp.lundimatin.fr/ Sinon Jérôme (Torcos) en a une copie, j'ai également une copie du ftp. J'éviterais Xamp car il doit être avec une version Php > 5.3, ce qui pour le moment n'est pas compatible avec Sooth ERP. Je viens d'installer Uwamp (http://www.uwamp.com/fr/) pour me refaire une plate forme de développement: c'est portable (pas d'installation au coeur du système) et on peut switcher la version de Php. J'aurais donc tendance à suggérer cela en remplacement de Xamp (même si on doit pouvoir lui réinstaller une version de Php, mais ce n'est pas forcément simple). Pour la communauté Sooth ERP, je ne vais pas prétendre qu'elle est hyper active: il y a un certain nombre de personnes intéressées par le projet, cela manque sans doute un peu d'émulation. Mais au fur et à mesure, la communauté progresse, il faut espérer qu'avec le nombre cela permettra un peu plus de dynamisme. En tout cas, si vous souhaitez contribuer, vous êtes plus que bienvenue. Cordialement, Yves
répondu Fev 10, 2014 par Yves (3,790 points)
Bonjour

merci pour votre réponse.

j'ai telechargé le contenu FTP de lundi matin, on ne sait jamais..

concernant uwamp, j'ai regardé. la version proposée au telechargement contient PHP 5.3.25 / 5.4.15.

donc appareemnt egalement supérieur à 5.3, mais le downgrade semble possible sur ce produit.

pour Xamp, j'avais installé en 2009 la version 1.7.1 qui semble répondre au critère PHP (5.2.9), ç'est sans doute pour cela que je galère avec les nouvelles versions..
Cette version XAMP 1.7.1 embarque MySQL 5.1.33 et apache 2.2.11. est-ce que ça convient ?

quelle version MySQL est optimum ?

concernant lundi matin, ils avaient un forum, très riche, une mine d'informations, truc et astuces.

auriez-vous une copie de ce forum ou l'url ?

PS suggestion : si vous activier le copier/coller sur le forum, ce srait plus pratique à mon sens.
Merci et bonne journée,

Cdlt, F Pacaud
Bonsoir, lorsque j'indiquais > 5.3, c'était strictement supérieur (i.e. Xamp a une version strictement supérieur à 5.3, non compatible à ce jour). La 5.2 n'est plus du tout maintenue, je déconseille. La 5.3 est en bout de course mais semble encore recevoir des patches de sécurité (5.3.28 en décembre 2013). A terme, il va falloir migrer, mais pour l'instant c'est la 5.3, d'où Uwamp. Je n'ai pas d'avis particulier sur Mysql / Apache car pas constaté de problème particulier si Mysql >= 5. J'ai rencontré de gros problèmes pour installer Mysql 5.5 sur Debian squeeze donc là je dirais 5.1 ou MariadB 5.5 (mais c'est plus par rapport à la facilité d'installation sur le système), sur Ubuntu pas de souci particulier sur 5.5 (c'est ce que j'utilise en dehors de Uwamp sur la plateforme dev que je viens de me recréer) Mais bon sous Win, honnêtement essayez Uwamp avec Php 5.3, vous ne prenez aucun risque il n'y a pas de réelle installation sur le système, c'est portable (ce qui peut d'ailleurs être utile) Cdt, Yves
Désolé, le formulaire ne me conserve pas les retours à la ligne, je ne sais pas pourquoi, à voir ...

Merci pour vos consiels.

pour le lien ftp lmb, j'ai remarqué qu'il y a un 2nd serveur FTP, peut être plus à jour ou simple mirroir du premier  : ftp://ftp2.lunfimatin.fr

Bonjour Yves,

il me faut atteindre la version 071 avant de pouvoir caresser l'espoir de migrer vers soothERP.

or j'ai réussi à remonter une maquette depuis la version 038 dont j'avais le package source, puis à upgrader jusqu'à 046 (ma version actuellement en prod), à réintérger ma sauvegarde.sql dans la base mySQL, puis à poursuivre l'assension des upgrade jusqu'à la 050. impeccable jusque là.

mais après cela ,  impossible de passer de 050 à 052. ça plante à tout les coup. ça dit en gros que vers la ligne 400 du fichier maj.php il y aurait un os dans la moulinette.. :-(

est-ce un problème bien connu ou suis-je sur une exeption qui risque de me pourrir la vie? :-( :(

merci par avance pour votre retour d'expérience.

Frederic.
Bonsoir,

Pour être honnete l'installation à partir du ftp LMB, notamment de versions assez anciennes commence à remonter pour moi et je ne connais pas toutes les possibilités de plantage (qui peuvent de plus être système dépendant j'imagine)

Il n'y a pas un message un peu plus précis que "il y a un os dans la moulinette" ? ;-)

Sinon il faudrait afficher les messages d'erreur Php (au cas où, quelques instructions http://www.inmotionhosting.com/support/website/php-troubleshooting/troubleshoot-php-errors )

Sur quelle plateforme installez vous au final ?

Yves
Bonjour Yves,
"os dans la moulinette" ne fait pas avancer le shimilblique.. vous avez raison  ;-) désolé.
au final, après de multiple tests, la plateforme la plus stable, de ma propre expérinece sur win2012, tant avec LMB 2.050 que SoothERP, s'avère XAMP 1.7.1 avec l'avantage de pouvoir faire tourner MySQL et Apache en tant que "SERVICES", c'est à dire sans aucune ouverture de session ! (ce que ne permettrait pas uWamp avec un lancement de tache automatique, car ouverture de session requise..)
Concernant l'upgrade LMB, ça coinse durant l'upgrade de v50 à v52. message "serveur en cours de maintenance" dans une page web dont l'url est localhost/monsite/site/__serveur_stopped.php  :-(
dans répertoire monsite/echange_lmb un fichier v2.052_break_points.tmp est apparu
il y a aussi un fichier log que je vais uploader via l'interface du portail "bug"
En fait j'ai tenté une réinstall depuis le site ftp LMB (comme ça faisait un bout de temps que je n'étais pas passé par cette voie.
Ceci dit l'install commence avec la V 2.060, or je ne dispose pas de version antérieure.

L'avez vous ? Je crois comprendre que vous êtes parti de la 2.038 si vous l'aviez en version vierge au niveau de la bdd, ce serait intéressant, ça permettrait de vérifier, voire de corriger les étapes qui plantent.

Yves
J'ai déjà posté cette même réponse, mais comme ça concerne plusieurs personnes et en attendant d'avoir un peu de temps pour centraliser l'info sur une page:

Après différents essais, je suis repassé sur Uniform Server dont j'ai découvert les récentes et intéressantes évolutions.
Sous Uwamp, ça passait mais le proccess devenait *un peu* usine à gaz.
Uniform Server permet maintenant de switcher les versions de Php (et bien plus) et la mise à jour passe sans avoir à toucher à la version de Mysql (ce qui n'était pas le cas avec Uwamp).

En résumé donc et pour donner une solution immédiate: en s’équipant de la dernière version de Uniform Server (http://sourceforge.net/projects/miniserver/files/Uniform%20Server%20ZeroXI/) et en rajoutant les modules Php 5.2 et 5.3 on peut faire la mise à jour:
- Php 5.2 pour la mise à jour, puis
- Php 5.3 pour l'utilisation

Je créerai une page plus complète sur le wiki quand je trouverai un petit moment.
...