Bienvenue sur la page communauté Sooth ERP, où vous pouvez poser vos questions. Inscrivez-vous (via le login de Mantis)

Bienvenue dans la communauté Sooth ERP.

Vous pouvez posez ici vos questions ou fournir des réponses aux autres membres de la communauté.

probleme migration LMB vers SOOTHERP

0 votes
Bonjour,
Je suis en version 2.071.0 LMB depuis longtemps sans aucun soucis.
Depuis le passage de 1&1 en php 5.4, LMB ne fonctionne plus.
Je désire donc passé sur SOOTHERP.

j'ai fais cette procésure :
- création nouvelle base de données chez 1&1
- export de ma base LMB et import dans cette nouvelle base >OK
- création d'une nouvelle directory sur le server
- copier coller de mon répertoire LMB dans cette nouvelle directory.
- copie du dossier config, fichier et modele_pdf de lmb vers la nouvelle.
- copie de tout les autres fichiers à partir de la source SOOTHERP 2.071.0

ajout dans la base de donnée  commerciaux categories de "note"

RESULTAT : a l'ouverture de la page, j'ai l'erreur suivante :

Fatal error: Call to undefined function affiche_version() in /homepages/20/d353361389/htdocs/SOOTHERP/_erreurs.lib.php on line 48

Je n'ai pas beaucoup de connaissance alors ???? comment faire ?

Merci de votre réponse, mes clients attendent des factures.
posté Oct 5, 2015 dans la catégorie Problèmes par docteur (120 points)

1 Réponse

0 votes
Bonjour,

je comprends que la situation est inconfortable si vos clients attendent.
Pour autant,  je pense que faire la migration directement sur votre version de production est un peu risqué puisque vous dites ne pas avoir beaucoup de connaissances. Or la version actuelle de Sootherp qui supporte le Php5.4 et l'utf8 est une version de développement qui peut nécessiter des interventions en attendant d'être consolidée.

Du coup, en période de transition, je m'orienterai vers une des solutions suivantes:
1/ prendre un hébergement qui supporte encore le Php5.3 pour votre version de LMB et migrer d'abord vers SoothERP RC1.1 https://wiki.sootherp.fr/doku.php?id=wiki:sootherp:migration_depuis_lmb
- en mutualisé (comme par exemple -aucune action chez eux mais je sais que c'est sérieux- https://www.dinhosting.fr/hebergement-web-mutualise.html )
- sur un vps / dédié avec  une distribution LTS qui par sa politique supporte le PHp5.3 pour un moment
- en local (sous windows je conseille http://www.uniformserver.com/)
2/ se faire épauler par quelqu'un qui a les connaissances (des développeurs pros utilisent Sootherp et connaissent le logiciel pour être en mesure de répondre aux problèmes)

Cette mise en garde étant faite, le message correspond à une fonction qui n'est pas trouvée, il y a un problème de chemin.

Pour la base de données, je pense que c'est OK par rapport à votre démarche.

Pour les fichiers:
Il faudrait déployer les fichiers correspondant à la version là https://github.com/yvesb/soothERP (lien zip à doite, les fichiers correspondent au sous dossier 2.071.0)

Puis ensuite rapatrier les éléments de configuration de votre version dans les fichiers config (les remplacer comme ça ne peut pas fonctionner, il y a des nouveaux paramètres etc). Un début de réponse ici pour la version RC1.1 https://wiki.sootherp.fr/doku.php?id=wiki:sootherp:migration_depuis_lmb mais pour la version compatible Php5.4 ce n'est pas encore documenté car elle n'est pas encore finalisée. Il faut vérifier les différences avec un logiciel de diff et les implémenter à la main (d'où le nécessité, je pense, d'avoir quelques connaissances ou de faire appel à quelqu'un qui les a).

Enfin pour le moment il existe un bug récent avec Firefox 41, donc si vous faites la migration totale utilisez Firefox 40

Cordialement
répondu Oct 6, 2015 par Yves (3,790 points)
modifié Oct 6, 2015 par Yves
...